Square degraded performance: Errors when processing payments
Incident Report for Checkfront
Resolved
This incident has been resolved by the upstream provider, Square.
Posted Aug 03, 2022 - 18:15 PDT
Update
transactions processed in Checkfront with Square from 11:45 AM PST to 3:48 PM PST may not be reflected or have duplicate payments on the Checkfront invoice. It is best to reference your Square Dashboard to reconcile your Checkfront bookings accurately.
Posted Aug 03, 2022 - 16:10 PDT
Monitoring
A fix has been implemented and we are monitoring the situation closely.
Posted Aug 03, 2022 - 15:50 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 03, 2022 - 15:36 PDT
Investigating
We are currently investigating an issue with Square not accepting payments. The issue appears to be on Square's end, and we are closely monitoring the situation.
Posted Aug 03, 2022 - 14:50 PDT
This incident affected: Canada (northamerica-northeast1), Europe (europe-west1), Australia (australia-southeast1), US (us-west1, us-central1, us-east1), Asia (asia-northeast1), and Site Builder, www.checkfront.com, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Cloud Networking, Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Compute Engine, Stripe Webhooks, Xero Ltd - API App Centre, Stripe API, Stripe JS, Stripe JS.