Database maintenance is taking longer than expected, we will be extending the maintenance window by an hour. We apologise for any inconvenience caused.
Posted May 06, 2025 - 17:44 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 06, 2025 - 16:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 05, 2025 - 20:46 PDT
Scheduled
Details: To improve performance and reliability, we’ll be upgrading our databases during a planned maintenance window.
When: Between 1:00 AM – 4:00 AM local time (CEST)
Date: 7th May 2025
Impact: Your site will remain available, but bookings will be temporarily paused (read-only mode).
Posted Apr 30, 2025 - 20:13 PDT
This scheduled maintenance affected: Europe (europe-west1).