Degraded Performance: Square Services
Incident Report for Checkfront
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 10:15 PDT
Monitoring
A fix has been implemented and Square is monitoring the results: https://ca.issquareup.com/
Posted Sep 08, 2023 - 09:27 PDT
Identified
Square is currently facing a service disruption that may affect payments in Checkfront. Please check Square's status page here for new updates: https://ca.issquareup.com/
Posted Sep 07, 2023 - 12:57 PDT