Staff & Partner Account settings page is causing page crashing

Incident Report for Checkfront

Resolved

We have deployed a resolution to the problem and functionality should be stabilizing as the deploy patches your account.
Posted Apr 22, 2022 - 18:02 PDT

Identified

We have identified the issue, and are implementing a fix.
Posted Apr 22, 2022 - 17:45 PDT

Investigating

We are currently investigating an issue that is causing User Account management pages to crash.
Posted Apr 22, 2022 - 17:34 PDT
This incident affected: Canada (northamerica-northeast1), Europe (europe-west1), Australia (australia-southeast1), US (us-west1, us-central1, us-east1), and Asia (asia-northeast1).