Next-Gen Account Access Issue: 504 Gateway Timeout Errors

Incident Report for Checkfront

Resolved

The issue affecting Next-Gen account access has been resolved, and services are operating normally.

During a cluster upgrade, a scaling issue prevented critical cluster components (including DNS) from starting correctly, resulting in 504 Gateway Timeout errors for some users. The issue has now been remediated and service fully restored.

We apologize for the disruption.
Posted Jun 08, 2026 - 12:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2026 - 12:24 PDT

Update

We are continuing to investigate this issue.
Posted Jun 08, 2026 - 12:14 PDT

Investigating

We are aware of an issue affecting Next-Gen account access, resulting in 504 Gateway Timeout errors for some users. Our team is actively investigating and working toward a resolution. We appreciate your patience while we work to restore service.
Posted Jun 08, 2026 - 12:13 PDT
This incident affected: Canada (northamerica-northeast1), Europe (europe-west1), Australia (australia-southeast1), US (us-west1, us-central1, us-east1), and Asia (asia-northeast1).